aboutsummaryrefslogtreecommitdiffstats
path: root/community/libsigc++/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libsigc++/APKBUILD')
-rw-r--r--community/libsigc++/APKBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/community/libsigc++/APKBUILD b/community/libsigc++/APKBUILD
index fa6ea6b9794..590e27afd1a 100644
--- a/community/libsigc++/APKBUILD
+++ b/community/libsigc++/APKBUILD
@@ -1,36 +1,32 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libsigc++
-pkgver=2.10.6
+pkgver=2.12.1
pkgrel=0
pkgdesc="type-safe Signal Framework for C++"
url="https://github.com/libsigcplusplus/libsigcplusplus"
arch="all"
license="LGPL-3.0-or-later"
-makedepends="meson perl doxygen graphviz libxslt"
-subpackages="$pkgname-dev $pkgname-doc"
+makedepends="meson docbook-xsl perl doxygen graphviz libxslt"
+subpackages="$pkgname-dev $pkgname-devhelp $pkgname-doc"
source="https://download.gnome.org/sources/libsigc++/${pkgver%.*}/libsigc++-$pkgver.tar.xz"
build() {
abuild-meson \
+ -Db_lto=true \
-Dbuild-documentation=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-doc() {
- default_doc
-
- mv "$pkgdir"/usr/share/devhelp "$subpkgdir"/usr/share
- rmdir "$pkgdir"/usr/share
-}
-
-sha512sums="7dd57c061defe323de5721d187145dcf63346311d8993eb6346a33789f26c8509c1bf5a73d55776cc5ebe85fb14d54107553a652dd42f452aed6aed20047b549 libsigc++-2.10.6.tar.xz"
+sha512sums="
+5e5c920807952c732a9acb139f707fdf556786133c18bc8842130803f864ba1f260e1d4a51be0a9892c2228bcfdf129a9a2ce91e3d20077870431a53a87a9f2a libsigc++-2.12.1.tar.xz
+"