aboutsummaryrefslogtreecommitdiffstats
path: root/community/libspecbleach/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libspecbleach/APKBUILD')
-rw-r--r--community/libspecbleach/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/libspecbleach/APKBUILD b/community/libspecbleach/APKBUILD
new file mode 100644
index 00000000000..e6d650c1037
--- /dev/null
+++ b/community/libspecbleach/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Magnus Sandin <magnus.sandin@gmail.com>
+# Maintainer: Magnus Sandin <magnus.sandin@gmail.com>
+pkgname=libspecbleach
+pkgver=0.1.6
+pkgrel=1
+pkgdesc="Standalone library based on the algorithms used in noise-repellent."
+url="https://github.com/lucianodato/libspecbleach"
+arch="all"
+license="LGPL-2.1-only"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
+makedepends="
+ fftw-dev
+ meson
+ "
+subpackages="$pkgname-dev"
+source="libspecbleach-$pkgver.tar.gz::https://github.com/lucianodato/libspecbleach/archive/refs/tags/v$pkgver.tar.gz"
+options="!check" # No tests available
+
+build() {
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C output
+}
+
+sha512sums="
+f6b64e55db556933066a489e2792830a0c34b5bfc365fedb190846ec98292c6e09f07fd2d7bcf97c81a5dfa64e8d66494ff3f2706de63964a222627cb86bfa25 libspecbleach-0.1.6.tar.gz
+"