aboutsummaryrefslogtreecommitdiffstats
path: root/community/libspectre/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libspectre/APKBUILD')
-rw-r--r--community/libspectre/APKBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/community/libspectre/APKBUILD b/community/libspectre/APKBUILD
index 59fd2b8347b..f43ff442e6d 100644
--- a/community/libspectre/APKBUILD
+++ b/community/libspectre/APKBUILD
@@ -2,10 +2,10 @@
# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=libspectre
-pkgver=0.2.9
-pkgrel=0
+pkgver=0.2.12
+pkgrel=1
pkgdesc="A small library for rendering Postscript documents"
-url="http://www.freedesktop.org/wiki/Software/libspectre"
+url="https://www.freedesktop.org/wiki/Software/libspectre"
arch="all"
license="LGPL-2.0-or-later"
makedepends="ghostscript-dev doxygen graphviz"
@@ -28,16 +28,6 @@ build() {
make doc
}
-package() {
- make DESTDIR="$pkgdir" install
-}
-
-doc() {
- mkdir -p "$subpkgdir/usr/share/doc/$pkgname"
- install -m644 "$builddir"/doc/html/* \
- "$subpkgdir/usr/share/doc/$pkgname/"
-}
-
check() {
cd "$builddir/test"
make
@@ -51,5 +41,17 @@ check() {
file work/document.png | grep -q "PNG image data" || error "Failed png test"
}
-sha512sums="7c24b5c83c6d356c89417d09dc76566afbe886ec189fe80d030a239c23ad25b061db071768117fa06805aa3d86f749fb232b7491bd7d467f26a40e348e74d5d2 libspectre-0.2.9.tar.gz
-c5148d38da69ebd125f66bb92204f2c7c79797d60a137d431122792c4e4cdcdb3a6a20cfadadd2821536449b1d638258f4596e43154e1ad2307bffa97af4908b test.ps"
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+doc() {
+ mkdir -p "$subpkgdir/usr/share/doc/$pkgname"
+ install -m644 "$builddir"/doc/html/* \
+ "$subpkgdir/usr/share/doc/$pkgname/"
+}
+
+sha512sums="
+3a4045c1e94e7de23b437393389397dd2448363458023b5aa8e43fa0553a160216f038e157374cefc1d09fa74711ad4899aac1fc353c482bd5fe970d9a97461f libspectre-0.2.12.tar.gz
+c5148d38da69ebd125f66bb92204f2c7c79797d60a137d431122792c4e4cdcdb3a6a20cfadadd2821536449b1d638258f4596e43154e1ad2307bffa97af4908b test.ps
+"