aboutsummaryrefslogtreecommitdiffstats
path: root/community/libspiro/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libspiro/APKBUILD')
-rw-r--r--community/libspiro/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/libspiro/APKBUILD b/community/libspiro/APKBUILD
new file mode 100644
index 00000000000..10b3e78d21d
--- /dev/null
+++ b/community/libspiro/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Ed Robinson <ed@reevoo.com>
+# Maintainer: Ed Robinson <ed@reevoo.com>
+pkgname=libspiro
+pkgver=20221101
+pkgrel=1
+pkgdesc="Library to simplify the drawing of beautiful curves"
+url="https://github.com/fontforge/libspiro"
+arch="all"
+license="GPL-3.0-or-later"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/fontforge/libspiro/releases/download/$pkgver/libspiro-dist-$pkgver.tar.gz"
+
+# secfixes:
+# 20200505-r0:
+# - CVE-2019-19847
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+a4fd1d225da94f4146b2d086f1c0d0111ca0b1efc1d1a051d4f1d995af424cf573072791118d6e0a5c06462ff1dd58b2ce662dbb6a46c6aa082c1319030899f8 libspiro-dist-20221101.tar.gz
+"