aboutsummaryrefslogtreecommitdiffstats
path: root/community/libspng/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libspng/APKBUILD')
-rw-r--r--community/libspng/APKBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/community/libspng/APKBUILD b/community/libspng/APKBUILD
index d1468958555..e751b85a6a0 100644
--- a/community/libspng/APKBUILD
+++ b/community/libspng/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Alex Yam <alex@alexyam.com>
# Maintainer: Alex Yam <alex@alexyam.com>
pkgname=libspng
-pkgver=0.7.2
+pkgver=0.7.4
pkgrel=0
pkgdesc="modern alternative to libpng"
url="https://github.com/randy408/libspng"
@@ -12,14 +12,23 @@ subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/randy408/libspng/archive/refs/tags/v$pkgver.tar.gz"
build() {
+ case "$CARCH" in
+ x86)
+ local sseopt=false
+ ;;
+ *)
+ local sseopt=true
+ ;;
+ esac
abuild-meson \
- -Ddefault_library=both \
+ -Db_lto=true \
+ -Denable_opt=$sseopt \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -27,5 +36,5 @@ package() {
}
sha512sums="
-924a8148aeb485ba229e99afc75dac794a7a281ca1b4c6f2993bc05d81f4d3e90ba6ad4beb76a8e78f1e0164c17ece5b10d1a4eca9cb5f3fb7a2de4e84010564 libspng-0.7.2.tar.gz
+cd729653599ed97f80d19f3048c1b3bc2ac16f922b3465804b1913bc45d9fc8b28b56bc2121fda36e9d3dcdd12612cced5383313b722a5342b613f8781879f1a libspng-0.7.4.tar.gz
"