aboutsummaryrefslogtreecommitdiffstats
path: root/community/libsrt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libsrt/APKBUILD')
-rw-r--r--community/libsrt/APKBUILD32
1 files changed, 13 insertions, 19 deletions
diff --git a/community/libsrt/APKBUILD b/community/libsrt/APKBUILD
index 58c55017526..ce8947739d6 100644
--- a/community/libsrt/APKBUILD
+++ b/community/libsrt/APKBUILD
@@ -1,39 +1,32 @@
# Contributor: Yohann DANELLO <yohann.danello@crans.org>
# Maintainer: Yohann DANELLO <yohann.danello@crans.org>
pkgname=libsrt
-pkgver=1.4.2
+pkgver=1.5.3
pkgrel=0
pkgdesc="Secure Reliable Transport (SRT)"
options="!check" # TestMuxer.IPv4_and_IPv6 fail when setting up IPv6
url="https://www.srtalliance.org/"
arch="all"
license="MPL-2.0"
-makedepends="cmake openssl-dev linux-headers"
+makedepends="cmake openssl-dev>3 linux-headers samurai"
checkdepends="gtest-dev"
subpackages="$pkgname-progs $pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/Haivision/srt/archive/v$pkgver.tar.gz
- fix-cmake.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Haivision/srt/archive/v$pkgver.tar.gz"
builddir="$srcdir/srt-$pkgver"
build() {
- if options_has "!check"; then
- _testing=OFF
- else
- _testing=ON
- fi
-
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- cmake -B build \
+ cmake -B build -G Ninja -Wno-dev \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_C_FLAGS="$CFLAGS" \
- -DENABLE_UNITTESTS=$_testing \
- -DENABLE_TESTING=$_testing \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
+ -DUSE_ENCLIB=openssl-evp \
+ -DENABLE_UNITTESTS="$(want_check && echo ON || echo OFF)" \
+ -DENABLE_TESTING="$(want_check && echo ON || echo OFF)" \
-DENABLE_STATIC=OFF \
- $CMAKE_CROSSOPTS .
+ $CMAKE_CROSSOPTS
cmake --build build
}
@@ -44,7 +37,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
progs() {
@@ -53,5 +46,6 @@ progs() {
amove usr/bin
}
-sha512sums="4c978e3898737e566f47222a0095df1b49591d79927850cc94c838b7eaccf401faf1c5d038fa45b6fd30c85f980e7c212a79c07ed6f9008430e8a5a594a31ffe libsrt-1.4.2.tar.gz
-c981710879f1bd83674ed9baeb394e33c5d18af7ca8f3ce92dc683f9d4ec36baeba56bbbc36371ce66d1e65441e33c6b82aecfaa32ee76b2bd9e3dc7feb7b815 fix-cmake.patch"
+sha512sums="
+5b576d6fd325515e05074e4568e3b65d1ae265e3e971db6e6242e5138243fc1594df1e3a7d90962385dac38abc34c4c4b0a567439050f8c0ff818b3b3d497efc libsrt-1.5.3.tar.gz
+"