aboutsummaryrefslogtreecommitdiffstats
path: root/community/libssh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libssh/APKBUILD')
-rw-r--r--community/libssh/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/community/libssh/APKBUILD b/community/libssh/APKBUILD
index bd4439142c2..1811a539873 100644
--- a/community/libssh/APKBUILD
+++ b/community/libssh/APKBUILD
@@ -1,21 +1,24 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libssh
-pkgver=0.9.6
-pkgrel=2
+pkgver=0.10.6
+pkgrel=0
pkgdesc="Library for accessing ssh client services through C libraries"
options="!check" # Tests require CLIENT_TESTING enabled which needs socket_wrapper
url="https://www.libssh.org/"
arch="all"
license="LGPL-2.1-or-later BSD-2-Clause"
depends_dev="openssl-dev>3 zlib-dev"
-makedepends="$depends_dev cmake doxygen"
+makedepends="$depends_dev cmake samurai"
checkdepends="cmocka-dev"
subpackages="$pkgname-dev"
-source="https://www.libssh.org/files/${pkgver%.*}/libssh-$pkgver.tar.xz
- "
+source="https://www.libssh.org/files/${pkgver%.*}/libssh-$pkgver.tar.xz"
# secfixes:
+# 0.10.6-r0:
+# - CVE-2023-6004
+# - CVE-2023-6918
+# - CVE-2023-48795
# 0.9.6-r0:
# - CVE-2021-3634
# 0.9.5-r0:
@@ -28,7 +31,8 @@ source="https://www.libssh.org/files/${pkgver%.*}/libssh-$pkgver.tar.xz
# - CVE-2018-10933
build() {
- cmake -B build \
+ CFLAGS="$CFLAGS -flto=auto" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -50,5 +54,5 @@ package() {
}
sha512sums="
-4040ec4af937e95be2e41313ef6d4db60b46b8d4dea10c09402398127c1d1ca8843392d207088aeee3c7ef631c6ae7b66861327dcebf78ed3af0723777619fd1 libssh-0.9.6.tar.xz
+40c62d63c44e882999b71552c237d73fc7364313bd00b15a211a34aeff1b73693da441d2c8d4e40108d00fb7480ec7c5b6d472f9c0784b2359a179632ab0d6c1 libssh-0.10.6.tar.xz
"