aboutsummaryrefslogtreecommitdiffstats
path: root/community/libssh/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libssh/APKBUILD')
-rw-r--r--community/libssh/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/community/libssh/APKBUILD b/community/libssh/APKBUILD
index 11dc9f5590b..18cd61bf649 100644
--- a/community/libssh/APKBUILD
+++ b/community/libssh/APKBUILD
@@ -1,9 +1,10 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libssh
-pkgver=0.9.4
+pkgver=0.9.5
pkgrel=0
pkgdesc="Library for accessing ssh client services through C libraries"
+options="!check" # Tests require CLIENT_TESTING enabled which needs socket_wrapper
url="https://www.libssh.org/"
arch="all"
license="LGPL-2.1-or-later BSD-2-Clause"
@@ -15,6 +16,8 @@ source="https://www.libssh.org/files/${pkgver%.*}/libssh-$pkgver.tar.xz
"
# secfixes:
+# 0.9.5-r0:
+# - CVE-2020-16135
# 0.9.4-r0:
# - CVE-2020-1730
# 0.9.3-r0:
@@ -29,7 +32,7 @@ build() {
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_LIBDIR=lib \
-DWITH_GSSAPI=OFF \
- -DUNIT_TESTING=ON
+ -DUNIT_TESTING=OFF
make
}
@@ -46,4 +49,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="38705c19c293ea5e6d286d22eb17021dbe58d88c1e647b699933aa0db9ca1174d43d1ff76c1a1b17bf2cc1a8297ec02f1a67dd9e969676dd69cf6fbdae9bc8d4 libssh-0.9.4.tar.xz"
+sha512sums="64e692a0bfa7f73585ea7b7b8b1d4c9a7f9be59565bfd4de32ca8cd9db121f87e7ad51f5c80269fbd99545af34dcf1894374ed8a6d6c1ac5f8601c026572ac18 libssh-0.9.5.tar.xz"