aboutsummaryrefslogtreecommitdiffstats
path: root/community/libsurvive/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libsurvive/APKBUILD')
-rw-r--r--community/libsurvive/APKBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/community/libsurvive/APKBUILD b/community/libsurvive/APKBUILD
index b4ec5926b33..70a18ff9317 100644
--- a/community/libsurvive/APKBUILD
+++ b/community/libsurvive/APKBUILD
@@ -1,38 +1,45 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libsurvive
-pkgver=0.3
-pkgrel=2
+pkgver=1.01
+pkgrel=4
pkgdesc="Open Source Lighthouse Tracking System"
url="https://github.com/cntools/libsurvive"
arch="all"
license="MIT"
depends="xr-hardware"
depends_dev="
- blas-dev
- lapack-dev
+ eigen-dev
libpcap-dev
libusb-dev
+ openblas-dev
zlib-dev
"
makedepends="$depends_dev
cmake
+ sciplot
+ "
+subpackages="$pkgname-static $pkgname-dev $pkgname-bash-completion $pkgname-web::noarch"
+source="https://github.com/cntools/libsurvive/releases/download/v$pkgver/libsurvive-v$pkgver-source.zip
+ off64_t.patch
"
-subpackages="$pkgname-static $pkgname-dev $pkgname-bash-completion $pkgname-web"
-source="$pkgname-$pkgver.tar.gz::https://github.com/cntools/libsurvive/archive/v$pkgver.tar.gz"
options="!check" # Requires live test data
+builddir="$srcdir/$pkgname"
build() {
cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_STATIC=OFF
+ -DBUILD_STATIC=OFF \
+ -DUSE_OPENBLAS=ON \
+ -DDOWNLOAD_EIGEN=OFF \
+ -DCMAKE_INSTALL_RPATH=/usr/lib/libsurvive/plugins
cmake --build build
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 useful_files/81-vive.rules "$pkgdir"/usr/lib/udev/rules.d/81-vive.rules
install -Dm644 survive_autocomplete.sh "$pkgdir"/usr/share/bash-completion/completions/survive
@@ -47,5 +54,6 @@ web() {
}
sha512sums="
-2aa87ae76993cf92c516786f86a61e249e3bc87a8f44c167440cdfc453af0c10f25dd2ede31b5a14f1950e944a3baa8f7cb81c159f6edbf6471e8542991b98d8 libsurvive-0.3.tar.gz
+6033d2524581bdefb0e1ed6e27c8044ba6ff32aa997845124c0b29d1a5a3f082a50605b2b654a642051ad0f22c6c8ad4ea8ca98888e28443d52ab68eb566effc libsurvive-v1.01-source.zip
+35ec5f53027fcf69ce335794f5b3e01421bb9d2ffbfec571703cdd136216f3f85794774b788cccd844ca9a803a605b5d6d7124b9d49767ea0614c6b2c869791b off64_t.patch
"