aboutsummaryrefslogtreecommitdiffstats
path: root/community/libsurvive/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libsurvive/APKBUILD')
-rw-r--r--community/libsurvive/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/community/libsurvive/APKBUILD b/community/libsurvive/APKBUILD
index ee291903f6a..70a18ff9317 100644
--- a/community/libsurvive/APKBUILD
+++ b/community/libsurvive/APKBUILD
@@ -2,18 +2,17 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libsurvive
pkgver=1.01
-pkgrel=0
+pkgrel=4
pkgdesc="Open Source Lighthouse Tracking System"
url="https://github.com/cntools/libsurvive"
arch="all"
license="MIT"
depends="xr-hardware"
depends_dev="
- blas-dev
eigen-dev
- lapack-dev
libpcap-dev
libusb-dev
+ openblas-dev
zlib-dev
"
makedepends="$depends_dev
@@ -21,16 +20,21 @@ makedepends="$depends_dev
sciplot
"
subpackages="$pkgname-static $pkgname-dev $pkgname-bash-completion $pkgname-web::noarch"
-source="https://github.com/cntools/libsurvive/releases/download/v$pkgver/libsurvive-v$pkgver-source.zip"
+source="https://github.com/cntools/libsurvive/releases/download/v$pkgver/libsurvive-v$pkgver-source.zip
+ off64_t.patch
+ "
options="!check" # Requires live test data
builddir="$srcdir/$pkgname"
build() {
cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_STATIC=OFF
+ -DBUILD_STATIC=OFF \
+ -DUSE_OPENBLAS=ON \
+ -DDOWNLOAD_EIGEN=OFF \
+ -DCMAKE_INSTALL_RPATH=/usr/lib/libsurvive/plugins
cmake --build build
}
@@ -51,4 +55,5 @@ web() {
sha512sums="
6033d2524581bdefb0e1ed6e27c8044ba6ff32aa997845124c0b29d1a5a3f082a50605b2b654a642051ad0f22c6c8ad4ea8ca98888e28443d52ab68eb566effc libsurvive-v1.01-source.zip
+35ec5f53027fcf69ce335794f5b3e01421bb9d2ffbfec571703cdd136216f3f85794774b788cccd844ca9a803a605b5d6d7124b9d49767ea0614c6b2c869791b off64_t.patch
"