aboutsummaryrefslogtreecommitdiffstats
path: root/community/libsysstat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libsysstat/APKBUILD')
-rw-r--r--community/libsysstat/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/libsysstat/APKBUILD b/community/libsysstat/APKBUILD
new file mode 100644
index 00000000000..d832ff56266
--- /dev/null
+++ b/community/libsysstat/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=libsysstat
+pkgver=0.4.6
+pkgrel=1
+pkgdesc="Library used to query system info and statistics"
+url="https://github.com/lxqt/libsysstat"
+arch="all"
+license="LGPL-2.1-or-later"
+subpackages="$pkgname-dev"
+makedepends="cmake samurai lxqt-build-tools qt5-qtbase-dev"
+options="!check" # No testsuite
+source="https://github.com/lxqt/libsysstat/releases/download/$pkgver/libsysstat-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+
+sha512sums="
+dd0e6f67509658691082b043e06589c6a89eea016a0e68cdb7d377f25a0bc63aa476b5eb90f230593daab462a9e22f6f636c0723110fb36faeea7c0aa6d0b85b libsysstat-0.4.6.tar.xz
+"