aboutsummaryrefslogtreecommitdiffstats
path: root/community/libtermkey/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libtermkey/APKBUILD')
-rw-r--r--community/libtermkey/APKBUILD10
1 files changed, 1 insertions, 9 deletions
diff --git a/community/libtermkey/APKBUILD b/community/libtermkey/APKBUILD
index 335e47761b9..d35f5f0817b 100644
--- a/community/libtermkey/APKBUILD
+++ b/community/libtermkey/APKBUILD
@@ -2,34 +2,26 @@
# Maintainer: Marvin Preuss <marvin@xsteadfastx.org>
pkgname=libtermkey
pkgver=0.22
-pkgrel=0
+pkgrel=1
pkgdesc="Library for easy processing of keyboard entry from terminal-based programs"
url="http://www.leonerd.org.uk/code/libtermkey"
arch="all"
license="MIT"
-depends=""
depends_dev="unibilium-dev"
makedepends="$depends_dev libtool perl perl-utils"
subpackages="$pkgname-doc $pkgname-dev"
source="http://www.leonerd.org.uk/code/libtermkey/$pkgname-$pkgver.tar.gz
build-static-lib.patch"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
-
make PREFIX=/usr
}
check() {
- cd "$builddir"
-
make test
}
package() {
- cd "$builddir"
-
make PREFIX=/usr DESTDIR="$pkgdir" install
}