aboutsummaryrefslogtreecommitdiffstats
path: root/community/libtorrent-rasterbar/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libtorrent-rasterbar/APKBUILD')
-rw-r--r--community/libtorrent-rasterbar/APKBUILD61
1 files changed, 31 insertions, 30 deletions
diff --git a/community/libtorrent-rasterbar/APKBUILD b/community/libtorrent-rasterbar/APKBUILD
index 3f6f876e933..c6bb0e4fa60 100644
--- a/community/libtorrent-rasterbar/APKBUILD
+++ b/community/libtorrent-rasterbar/APKBUILD
@@ -1,29 +1,35 @@
# Contributor: August Klein <amatcoder@gmail.com>
-# Maintainer: August Klein <amatcoder@gmail.com>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=libtorrent-rasterbar
-pkgver=2.0.5
-pkgrel=1
+pkgver=2.0.10
+pkgrel=0
pkgdesc="Feature complete C++ bittorrent implementation"
url="https://www.rasterbar.com/products/libtorrent"
arch="all"
license="BSD-3-Clause"
-depends_dev="boost-dev openssl-dev"
-makedepends="$depends_dev cmake linux-headers python3-dev py3-setuptools"
+depends_dev="boost-dev openssl-dev>3"
+makedepends="$depends_dev cmake linux-headers python3-dev py3-setuptools samurai"
subpackages="py3-$pkgname:_py3 $pkgname-dev"
source="https://github.com/arvidn/libtorrent/releases/download/v$pkgver/libtorrent-rasterbar-$pkgver.tar.gz"
+case "$CARCH" in
+arm*|x86)
+ # fail to build on 32-bit
+ options="$options !check"
+ ;;
+*)
+ ;;
+esac
+
build() {
- # disable assertions without release build type
- export CXXFLAGS="$CXXFLAGS -DNDEBUG"
- cmake -B build \
+ CXXFLAGS="$CXXFLAGS -O2 -DNDEBUG -flto=auto" \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_STANDARD=17 \
- -DCMAKE_VERBOSE_MAKEFILE=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
- -Dbuild_tests=ON \
+ -Dbuild_tests="$(want_check && echo ON || echo OFF)" \
-Dpython-bindings=ON \
-Dpython-egg-info=ON
-
cmake --build build
}
@@ -31,18 +37,19 @@ check() {
# upnp: relies on upnp networking setup
# flags: fails randomly, on 32-bit and aarch64
# remove_torrent: random failures when running multiple tests at once
- local tests_to_skip="test_upnp|test_flags|test_remove_torrent"
+ # privacy: flaky on port allocation
+ local tests_to_skip="test_upnp|test_flags|test_remove_torrent|test_privacy"
+
+ # broken
+ tests_to_skip="$tests_to_skip|test_create_torrent"
- case "$CARCH" in
- x86)
- # url_seed: unknown failures
- # session_params: fails on builders only for x86
- tests_to_skip="$tests_to_skip|test_url_seed|test_session_params"
- ;;
- esac
+ # fails on btrfs?
+ tests_to_skip="$tests_to_skip|test_copy_file"
- export CTEST_PARALLEL_LEVEL=$JOBS # TODO: abuild !122
- ctest --output-on-failure --test-dir build --exclude-regex "$tests_to_skip"
+ # flaky
+ tests_to_skip="$tests_to_skip|test_web_seed|test_url_seed|test_transfer|test_ssl"
+
+ ctest -j4 --output-on-failure --test-dir build --exclude-regex "$tests_to_skip"
}
package() {
@@ -56,17 +63,11 @@ dev() {
}
_py3() {
- pkgdesc="Python3 bindings for $pkgname"
- local _py3ver=$(python3 -c 'import sys; print(f"{sys.version_info.major}.{sys.version_info.minor}")')
-
- # the python bindings are a single .so under python site-packages
- amove "usr/lib/python$_py3ver"
+ pkgdesc="$pkgdesc (python bindings)"
- # fix version string
- sed -i "s/^Version:.*/Version: $pkgver/" \
- "$subpkgdir/usr/lib/python$_py3ver/site-packages/libtorrent.egg-info/PKG-INFO"
+ amove usr/lib/python3*
}
sha512sums="
-be5b812135dada957e565085b5bdda06827c8427f78a4468ef263e1a1e33d3a0bbba7ac27235f0d17ae6087d54311281e3b1975eef81cda514acc8329862dc04 libtorrent-rasterbar-2.0.5.tar.gz
+a6406ccdd1d0c8d42543419a3b9edca880ab85e0849bfba29e3b1bd98f9630244aa3e88110cdf95e476792c9ea87a141fcb16a8c3b3e0c44c0076ebf6f9adbee libtorrent-rasterbar-2.0.10.tar.gz
"