aboutsummaryrefslogtreecommitdiffstats
path: root/community/libtorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libtorrent/APKBUILD')
-rw-r--r--community/libtorrent/APKBUILD26
1 files changed, 20 insertions, 6 deletions
diff --git a/community/libtorrent/APKBUILD b/community/libtorrent/APKBUILD
index f7493ab47f4..59dc0deb754 100644
--- a/community/libtorrent/APKBUILD
+++ b/community/libtorrent/APKBUILD
@@ -3,15 +3,27 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=libtorrent
pkgver=0.13.8
-pkgrel=0
+pkgrel=3
pkgdesc="BitTorrent library written in C++"
url="https://rakshasa.github.io/rtorrent"
-# riscv64 blocked by polkit -> kio
-arch="all !riscv64"
+arch="all"
license="GPL-2.0-or-later"
-makedepends="zlib-dev libsigc++-dev openssl-dev automake autoconf libtool linux-headers"
+makedepends="
+ autoconf
+ automake
+ libsigc++-dev
+ libtool
+ linux-headers
+ openssl-dev>3
+ zlib-dev
+ "
subpackages="$pkgname-dev"
-source="https://rtorrent.net/downloads/$pkgname-$pkgver.tar.gz"
+source="https://github.com/rakshasa/rtorrent-archive/raw/master/libtorrent-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
build() {
./autogen.sh
@@ -28,4 +40,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="417177df5b27cd8c6a6317063b0846da2690de4633836466728605c2edad2de407d29d321cc481b8d1352dd0ff6dd89f4566a830424a8cf986f2fddb04704da4 libtorrent-0.13.8.tar.gz"
+sha512sums="
+417177df5b27cd8c6a6317063b0846da2690de4633836466728605c2edad2de407d29d321cc481b8d1352dd0ff6dd89f4566a830424a8cf986f2fddb04704da4 libtorrent-0.13.8.tar.gz
+"