aboutsummaryrefslogtreecommitdiffstats
path: root/community/libtorrent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libtorrent/APKBUILD')
-rw-r--r--community/libtorrent/APKBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/community/libtorrent/APKBUILD b/community/libtorrent/APKBUILD
index dba4e93b4b8..ceaa128d020 100644
--- a/community/libtorrent/APKBUILD
+++ b/community/libtorrent/APKBUILD
@@ -1,28 +1,23 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-
pkgname=libtorrent
pkgver=0.13.8
pkgrel=0
pkgdesc="BitTorrent library written in C++"
-url="http://rakshasa.github.io/rtorrent/"
+url="https://rakshasa.github.io/rtorrent"
arch="all"
-license="GPL"
+license="GPL-2.0-or-later"
makedepends="zlib-dev libsigc++-dev openssl-dev automake autoconf libtool linux-headers"
subpackages="$pkgname-dev"
-source="http://rtorrent.net/downloads/$pkgname-$pkgver.tar.gz
- 0001-Fix-the-DH-parameters-generation-with-OpenSSL-1.1.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://rtorrent.net/downloads/$pkgname-$pkgver.tar.gz"
prepare() {
default_prepare
- cd "$builddir"
./autogen.sh
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,9 +28,7 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="417177df5b27cd8c6a6317063b0846da2690de4633836466728605c2edad2de407d29d321cc481b8d1352dd0ff6dd89f4566a830424a8cf986f2fddb04704da4 libtorrent-0.13.8.tar.gz
-3cb44b4965149a9c70a9390104d5918dcb69671aa5d9ee3efa2f1c32b36f84619261a3b474c9651d040b60fe29ecbc42ba494ed7267443db0e865ebf9a2f79ce 0001-Fix-the-DH-parameters-generation-with-OpenSSL-1.1.patch"
+sha512sums="417177df5b27cd8c6a6317063b0846da2690de4633836466728605c2edad2de407d29d321cc481b8d1352dd0ff6dd89f4566a830424a8cf986f2fddb04704da4 libtorrent-0.13.8.tar.gz"