aboutsummaryrefslogtreecommitdiffstats
path: root/community/libuser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libuser/APKBUILD')
-rw-r--r--community/libuser/APKBUILD41
1 files changed, 27 insertions, 14 deletions
diff --git a/community/libuser/APKBUILD b/community/libuser/APKBUILD
index df1a5c461b6..cee49747333 100644
--- a/community/libuser/APKBUILD
+++ b/community/libuser/APKBUILD
@@ -1,23 +1,36 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=libuser
-pkgver=0.62
-pkgrel=5
-pkgdesc="A standardized interface for manipulating and administering user and group accounts"
+pkgver=0.64
+pkgrel=1
+pkgdesc="Standardized interface for manipulating and administering user and group accounts"
url="https://pagure.io/libuser"
arch="all"
license="LGPL-2.0-or-later"
depends="python3"
-makedepends="python3-dev glib-dev popt-dev libexecinfo-dev linux-pam-dev
- autoconf automake libtool gtk-doc"
+makedepends="
+ autoconf
+ automake
+ bison
+ flex
+ gettext-dev
+ glib-dev
+ glib-dev
+ gtk-doc
+ libtool
+ linux-pam-dev
+ popt-dev
+ python3-dev
+ xz
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py3-$pkgname:_py"
-source="https://releases.pagure.org/libuser/libuser-$pkgver.tar.xz
+source="https://releases.pagure.org/libuser/libuser-$pkgver.tar.gz
0001-remove-unused-execinfo.h.patch
"
prepare() {
default_prepare
- autoreconf -vif
+ sh autogen.sh
}
build() {
@@ -25,8 +38,8 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--sbindir=/usr/bin \
- --with-python \
--disable-gtk-doc-html \
+ --with-python \
--disable-rpath \
--with-python=/usr/bin/python3
sed -i 's/SUBDIRS = po docs/SUBDIRS = po/' Makefile
@@ -38,12 +51,12 @@ package() {
}
_py() {
- cd "$builddir"
pkgdesc="Python3 bindings for $pkgname"
- depends="$pkgname"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib
+
+ amove usr/lib/python3*
}
-sha512sums="bc2f68456eae5912ac236192e97a3d66d5fa782520eff48d44d391c1ade590e001d821d7a93499e2391d0310cf03f60e4411f045f6ee3301af4e174d9ddc8450 libuser-0.62.tar.xz
-b7da24da834b7e00e3449ab49c2187b0d8993079888b0900b62ec418db8fc025a22ee4b779715cc6ca327b614d97dd1fbf0a33f4f22fedade06782a3ba11f599 0001-remove-unused-execinfo.h.patch"
+sha512sums="
+8a2536f8f37538e60a4d0eb072c69d56d6d27d39a34078576b33b6eff55e60534b3fdee6432fe591a1bfbd521a6a447746e42756e34f77e369d057d79562f74b libuser-0.64.tar.gz
+b7da24da834b7e00e3449ab49c2187b0d8993079888b0900b62ec418db8fc025a22ee4b779715cc6ca327b614d97dd1fbf0a33f4f22fedade06782a3ba11f599 0001-remove-unused-execinfo.h.patch
+"