aboutsummaryrefslogtreecommitdiffstats
path: root/community/libwacom/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libwacom/APKBUILD')
-rw-r--r--community/libwacom/APKBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/community/libwacom/APKBUILD b/community/libwacom/APKBUILD
index 0213ca4b6b2..8833f31fd1f 100644
--- a/community/libwacom/APKBUILD
+++ b/community/libwacom/APKBUILD
@@ -1,14 +1,22 @@
# Contributor: Ivan Tham <pickfire@riseup.net>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=libwacom
-pkgver=2.2.0
+pkgver=2.10.0
pkgrel=0
pkgdesc="Library to help implement Wacom tablet settings"
url="https://github.com/linuxwacom/libwacom/wiki"
arch="all"
license="MIT"
depends="eudev"
-makedepends="glib-dev libgudev-dev meson py3-libevdev py3-udev py3-pytest"
+makedepends="
+ glib-dev
+ libevdev-dev
+ libgudev-dev
+ meson
+ py3-libevdev
+ py3-pytest
+ py3-udev
+ "
checkdepends="bash findutils diffutils libxml2-dev"
subpackages="$pkgname-dev $pkgname-doc"
install="$pkgname.post-install $pkgname.post-upgrade"
@@ -22,11 +30,11 @@ build() {
-Dtests="$(options_has !check && echo disabled || echo enabled)" \
-Dudev-dir="/lib/udev" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -34,6 +42,6 @@ package() {
}
sha512sums="
-7347bd698a64ca878f8cb3ce6de6194488b8096a398d83bb018c31468f7d19e77382684d30f9e4573e18e1b82c4a14ae7d200daae63455aa172340bf513a1f9c libwacom-2.2.0.tar.gz
-50cf7a2bf288f6d27148e264f36df1463b9e22186a8c227803c644bfe4393bb0b8e6b5e922083116b269e88b0974de353905ab93f1727474c3404d83412482da 0001-udevadm.patch
+45bf65d5ac500214b638593e058cf2259d0c0ca955fc279d777054de9145ecc25121408a77486e2588c142d4308da8664571f305f9f4e900eefd0e5a4a695cff libwacom-2.10.0.tar.gz
+f1dd2376782584a71e84fedb83f6c3633e8b27977c6f65b3dc9db20dd0c8b761df44645d40049aef005f6ee6d7ce7496f5971306b9af778c36e59a4823235869 0001-udevadm.patch
"