aboutsummaryrefslogtreecommitdiffstats
path: root/community/libwacom/disable-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/libwacom/disable-tests.patch')
-rw-r--r--community/libwacom/disable-tests.patch26
1 files changed, 15 insertions, 11 deletions
diff --git a/community/libwacom/disable-tests.patch b/community/libwacom/disable-tests.patch
index b1028595827..3ecf9defc89 100644
--- a/community/libwacom/disable-tests.patch
+++ b/community/libwacom/disable-tests.patch
@@ -1,8 +1,8 @@
diff --git a/meson.build b/meson.build
-index 6584c86..9368567 100644
+index 41ea756..43262c7 100644
--- a/meson.build
+++ b/meson.build
-@@ -392,13 +392,6 @@ test('svg-layout-exists',
+@@ -410,13 +410,6 @@ test('svg-layout-exists',
args: [meson.source_root()],
suite: ['all'])
@@ -16,18 +16,22 @@ index 6584c86..9368567 100644
############### tools ###########################
executable('libwacom-list-local-devices',
-@@ -533,13 +526,6 @@ if get_option('tests')
+@@ -552,18 +545,6 @@ if get_option('tests')
message('valgrind not found, disabling valgrind test suite')
endif
-- test_deprecated = executable('test-deprecated',
-- 'test/test-deprecated.c',
-- dependencies: [dep_libwacom, dep_dl],
-- include_directories: [includes_src],
-- c_args: tests_cflags,
-- install: false)
-- test('test-deprecated', test_deprecated, suite: ['all'])
+- # because of the tricks we use in calling the function and exposing
+- # it to begin with, LTO gets confused and this fails to link.
+- # Let's just disable it here.
+- if not get_option('b_lto')
+- test_deprecated = executable('test-deprecated',
+- 'test/test-deprecated.c',
+- dependencies: [dep_libwacom, dep_dl],
+- include_directories: [includes_src],
+- c_args: tests_cflags,
+- install: false)
+- test('test-deprecated', test_deprecated, suite: ['all'])
+- endif
endif
# This is a non-optional test
-