aboutsummaryrefslogtreecommitdiffstats
path: root/community/libwpe/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libwpe/APKBUILD')
-rw-r--r--community/libwpe/APKBUILD28
1 files changed, 11 insertions, 17 deletions
diff --git a/community/libwpe/APKBUILD b/community/libwpe/APKBUILD
index cda8b0631c6..9391b50b064 100644
--- a/community/libwpe/APKBUILD
+++ b/community/libwpe/APKBUILD
@@ -1,34 +1,28 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libwpe
-pkgver=1.12.0
-pkgrel=1
+pkgver=1.14.2
+pkgrel=0
pkgdesc="General-purpose library specifically developed for the WPE-flavored port of WebKit"
url="https://wpewebkit.org/"
arch="all"
license="BSD-2-Clause"
-makedepends="cmake mesa-dev libxkbcommon-dev samurai"
+makedepends="mesa-dev meson libxkbcommon-dev"
options="!check" # no tests
-subpackages="$pkgname-dev $pkgname-dbg"
+subpackages="$pkgname-dbg $pkgname-dev"
source="https://github.com/WebPlatformForEmbedded/libwpe/releases/download/$pkgver/libwpe-$pkgver.tar.xz"
build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake -B build -G Ninja \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- $CMAKE_CROSSOPTS
- cmake --build build
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
package() {
- DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="
-d85865fd6f2dd907589a4d2c1b956d9a2093f72f5b7f755ab2bef040f7f26a73ddadd47a607a78578dec6eb6d59f44e18fa8b96a71f7bd19f3d62073f3ca6fee libwpe-1.12.0.tar.xz
+2c7b14190a55adcb9f45281715c5238e746ca85b8e50c655974b3a5e359472162bd87a5a40d13b73811e76d34d705614968bb6bdf8bf01c90504ce11e4b30e56 libwpe-1.14.2.tar.xz
"