aboutsummaryrefslogtreecommitdiffstats
path: root/community/libwpe/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libwpe/APKBUILD')
-rw-r--r--community/libwpe/APKBUILD30
1 files changed, 12 insertions, 18 deletions
diff --git a/community/libwpe/APKBUILD b/community/libwpe/APKBUILD
index 2ec67828643..9391b50b064 100644
--- a/community/libwpe/APKBUILD
+++ b/community/libwpe/APKBUILD
@@ -1,34 +1,28 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libwpe
-pkgver=1.10.0
+pkgver=1.14.2
pkgrel=0
pkgdesc="General-purpose library specifically developed for the WPE-flavored port of WebKit"
url="https://wpewebkit.org/"
arch="all"
license="BSD-2-Clause"
-makedepends="cmake mesa-dev libxkbcommon-dev"
+makedepends="mesa-dev meson libxkbcommon-dev"
options="!check" # no tests
-subpackages="$pkgname-dev $pkgname-dbg"
+subpackages="$pkgname-dbg $pkgname-dev"
source="https://github.com/WebPlatformForEmbedded/libwpe/releases/download/$pkgver/libwpe-$pkgver.tar.xz"
build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS" \
- $CMAKE_CROSSOPTS .
- make
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="b5634dd71cca70eb960f3c045ad109346ab6ce6b01aa8c8bc8f326d232eb16ac1600757896a4b99720af3c77084351ea4f69e2e2c81b9c32cc8bc12a5c66ba3c libwpe-1.10.0.tar.xz"
+sha512sums="
+2c7b14190a55adcb9f45281715c5238e746ca85b8e50c655974b3a5e359472162bd87a5a40d13b73811e76d34d705614968bb6bdf8bf01c90504ce11e4b30e56 libwpe-1.14.2.tar.xz
+"