aboutsummaryrefslogtreecommitdiffstats
path: root/community/libwpebackend-fdo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libwpebackend-fdo/APKBUILD')
-rw-r--r--community/libwpebackend-fdo/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/libwpebackend-fdo/APKBUILD b/community/libwpebackend-fdo/APKBUILD
index 41eb7bdeb93..e08174f5bfd 100644
--- a/community/libwpebackend-fdo/APKBUILD
+++ b/community/libwpebackend-fdo/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libwpebackend-fdo
-pkgver=1.12.0
-pkgrel=0
+pkgver=1.14.2
+pkgrel=1
pkgdesc="freedesktop.org backend for WPE WebKit"
url="https://wpewebkit.org/"
arch="all"
@@ -15,8 +15,12 @@ source="https://github.com/Igalia/WPEBackend-fdo/releases/download/$pkgver/wpeba
builddir="$srcdir/wpebackend-fdo-$pkgver"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ CFLAGS="${CFLAGS/-g/-g1}" \
+ CXXFLAGS="${CXXFLAGS/-g/-g1}" \
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
package() {
@@ -31,5 +35,5 @@ dev() {
}
sha512sums="
-856885394872ad3f205b600caecbae48ae0c51185a8e19e66add93222e49bb1b060cdc77f5c9269d43509a0b85af0b5642c27f951d1c9836d8616aa51a9180a5 wpebackend-fdo-1.12.0.tar.xz
+4edc28221795b325977f9a5a79b7656b4f100129a6d1c15142180bab94cce1a8b06b42a71fbe985ddc1e02772f1cc03a92f73d2176edd16e791db799b831740c wpebackend-fdo-1.14.2.tar.xz
"