aboutsummaryrefslogtreecommitdiffstats
path: root/community/libwpebackend-fdo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libwpebackend-fdo/APKBUILD')
-rw-r--r--community/libwpebackend-fdo/APKBUILD24
1 files changed, 18 insertions, 6 deletions
diff --git a/community/libwpebackend-fdo/APKBUILD b/community/libwpebackend-fdo/APKBUILD
index 91e7f3073b5..e08174f5bfd 100644
--- a/community/libwpebackend-fdo/APKBUILD
+++ b/community/libwpebackend-fdo/APKBUILD
@@ -1,12 +1,13 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libwpebackend-fdo
-pkgver=1.10.0
-pkgrel=0
+pkgver=1.14.2
+pkgrel=1
pkgdesc="freedesktop.org backend for WPE WebKit"
url="https://wpewebkit.org/"
arch="all"
license="BSD-2-Clause"
+depends_dev="$pkgname"
makedepends="mesa-dev meson glib-dev wayland-dev libwpe-dev libepoxy-dev"
options="!check" # no tests
subpackages="$pkgname-dbg $pkgname-dev"
@@ -14,14 +15,25 @@ source="https://github.com/Igalia/WPEBackend-fdo/releases/download/$pkgver/wpeba
builddir="$srcdir/wpebackend-fdo-$pkgver"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ CFLAGS="${CFLAGS/-g/-g1}" \
+ CXXFLAGS="${CXXFLAGS/-g/-g1}" \
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
+dev() {
+ default_dev
+
+ # this .so symlink needs to be in the main package
+ mv "$subpkgdir"/usr/lib/libWPEBackend-fdo-1.0.so "$pkgdir"/usr/lib
+}
+
sha512sums="
-50e65d1560b943ec85b80449c838b61d7ab3baf96844542cce06028bd934b1145319f3fa07a3dc629d2a7896b95ab388edbe853b7e377cf0ff02fb66291e1ce0 wpebackend-fdo-1.10.0.tar.xz
+4edc28221795b325977f9a5a79b7656b4f100129a6d1c15142180bab94cce1a8b06b42a71fbe985ddc1e02772f1cc03a92f73d2176edd16e791db799b831740c wpebackend-fdo-1.14.2.tar.xz
"