aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxcvt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libxcvt/APKBUILD')
-rw-r--r--community/libxcvt/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/libxcvt/APKBUILD b/community/libxcvt/APKBUILD
new file mode 100644
index 00000000000..75c64194b64
--- /dev/null
+++ b/community/libxcvt/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Milan P. Stanić <mps@arvanta.net>
+# Maintainer: Milan P. Stanić <mps@arvanta.net>
+pkgname=libxcvt
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="xorg xcvt library and cvt program"
+url="https://gitlab.freedesktop.org/xorg/lib/libxcvt"
+arch="all"
+license="custom"
+# older xorg-server versions included this package but it has since been split out
+# make sure we can upgrade properly to xorg-server 21.1.1 and later
+replaces="xorg-server<21.1.1"
+makedepends="meson"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://xorg.freedesktop.org/releases/individual/lib/libxcvt-$pkgver.tar.xz"
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ install -D -m644 "$srcdir"/$pkgname-$pkgver/COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+doc() {
+ default_doc
+
+ replaces="xorg-server-doc<21.1.1"
+}
+
+sha512sums="
+3f6b2baca712a4608780686932f8881255c07bb74b1a788f9b07d4e22975c038d75111cd6b452257882a0b2bad57eebb2002f80a3e435d2e2d16936597f039b0 libxcvt-0.1.2.tar.xz
+"