aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxcvt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libxcvt/APKBUILD')
-rw-r--r--community/libxcvt/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/community/libxcvt/APKBUILD b/community/libxcvt/APKBUILD
index ad7a9fa6573..75c64194b64 100644
--- a/community/libxcvt/APKBUILD
+++ b/community/libxcvt/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=libxcvt
-pkgver=0.1.1
-pkgrel=2
+pkgver=0.1.2
+pkgrel=0
pkgdesc="xorg xcvt library and cvt program"
url="https://gitlab.freedesktop.org/xorg/lib/libxcvt"
arch="all"
@@ -15,18 +15,12 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://xorg.freedesktop.org/releases/individual/lib/libxcvt-$pkgver.tar.xz"
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
- . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -42,5 +36,5 @@ doc() {
}
sha512sums="
-50e9cd0283858823d4cfde75f06e23ffc42983272cb1f75408052fb5b76a4bb6f9de7d42d8ff9ec0dae6e95eefebc6273e03c919a92f237585db55eaf1a57005 libxcvt-0.1.1.tar.xz
+3f6b2baca712a4608780686932f8881255c07bb74b1a788f9b07d4e22975c038d75111cd6b452257882a0b2bad57eebb2002f80a3e435d2e2d16936597f039b0 libxcvt-0.1.2.tar.xz
"