aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxmlb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libxmlb/APKBUILD')
-rw-r--r--community/libxmlb/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/community/libxmlb/APKBUILD b/community/libxmlb/APKBUILD
index 24cdf5a54ba..ffb0ac87453 100644
--- a/community/libxmlb/APKBUILD
+++ b/community/libxmlb/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Pablo Correa Gomez <ablocorrea@hotmail.com>
pkgname=libxmlb
-pkgver=0.3.7
+pkgver=0.3.19
pkgrel=0
pkgdesc="Library to help create and query binary XML blobs"
url="https://github.com/hughsie/libxmlb"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="meson glib-dev gobject-introspection-dev xz-dev"
+makedepends="meson glib-dev gobject-introspection-dev xz-dev zstd-dev"
checkdepends="shared-mime-info"
-subpackages="$pkgname-dev:_dev $pkgname-dbg"
-source="$pkgname-$pkgver.tar.gz::https://github.com/hughsie/libxmlb/archive/$pkgver.tar.gz"
+subpackages="$pkgname-dev:_dev $pkgname-dbg $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hughsie/libxmlb/archive/refs/tags/$pkgver.tar.gz"
build() {
abuild-meson \
@@ -19,11 +19,11 @@ build() {
-Dstemmer=false \
-Dintrospection=true \
output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -34,10 +34,10 @@ package() {
_dev() {
default_dev
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/libexec "$subpkgdir"/usr
+
+ amove usr/bin/xb-tool
}
sha512sums="
-398d49e190aedd5c1f0eab2a8b6ddf5fc1cd866d575459c049e55399fc8fb54512783cc024b8f3016fbf19232502ba86781eea5b937871a3aed25b5ed28a5edd libxmlb-0.3.7.tar.gz
+07db2e99b2f78f6e99cccbf5ca250978955d5a9bf18aaa675b2292d1df438fc3f98a5d0e8ddcfa41e686782f35947fe92b54b520b4e6e278d6e5c871e7491271 libxmlb-0.3.19.tar.gz
"