aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxmlb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libxmlb/APKBUILD')
-rw-r--r--community/libxmlb/APKBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/community/libxmlb/APKBUILD b/community/libxmlb/APKBUILD
index 98d04b2ee16..ffb0ac87453 100644
--- a/community/libxmlb/APKBUILD
+++ b/community/libxmlb/APKBUILD
@@ -1,42 +1,43 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Pablo Correa Gomez <ablocorrea@hotmail.com>
pkgname=libxmlb
-pkgver=0.1.14
+pkgver=0.3.19
pkgrel=0
pkgdesc="Library to help create and query binary XML blobs"
url="https://github.com/hughsie/libxmlb"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="meson glib-dev gobject-introspection-dev"
+makedepends="meson glib-dev gobject-introspection-dev xz-dev zstd-dev"
checkdepends="shared-mime-info"
-subpackages="$pkgname-dev:_dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/hughsie/libxmlb/archive/$pkgver.tar.gz"
+subpackages="$pkgname-dev:_dev $pkgname-dbg $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hughsie/libxmlb/archive/refs/tags/$pkgver.tar.gz"
build() {
- meson \
- --prefix=/usr \
+ abuild-meson \
-Dgtkdoc=false \
-Dtests=true \
-Dstemmer=false \
-Dintrospection=true \
- build
- ninja -C build
+ output
+ meson compile -C output
}
check() {
- ninja -C build test
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
rm -rf "$pkgdir"/usr/share/installed-tests
rm -rf "$pkgdir"/usr/libexec/installed-tests
}
_dev() {
default_dev
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/libexec "$subpkgdir"/usr
+
+ amove usr/bin/xb-tool
}
-sha512sums="906340212ce4a515bec81a1b7a5f04539712a48322d7fcff0992f82e5676cdf15c38b0340c28c9eed65a58321e3e17bac641f05bd403504c87599327ba6d4e49 libxmlb-0.1.14.tar.gz"
+sha512sums="
+07db2e99b2f78f6e99cccbf5ca250978955d5a9bf18aaa675b2292d1df438fc3f98a5d0e8ddcfa41e686782f35947fe92b54b520b4e6e278d6e5c871e7491271 libxmlb-0.3.19.tar.gz
+"