aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxmlb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libxmlb/APKBUILD')
-rw-r--r--community/libxmlb/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/libxmlb/APKBUILD b/community/libxmlb/APKBUILD
index 455e2aa20bc..d82ad60ab2e 100644
--- a/community/libxmlb/APKBUILD
+++ b/community/libxmlb/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Pablo Correa Gomez <ablocorrea@hotmail.com>
pkgname=libxmlb
-pkgver=0.2.1
-pkgrel=1
+pkgver=0.3.18
+pkgrel=0
pkgdesc="Library to help create and query binary XML blobs"
url="https://github.com/hughsie/libxmlb"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="meson glib-dev gobject-introspection-dev py3-setuptools"
+makedepends="meson glib-dev gobject-introspection-dev xz-dev zstd-dev"
checkdepends="shared-mime-info"
-subpackages="$pkgname-dev:_dev $pkgname-dbg"
-source="$pkgname-$pkgver.tar.gz::https://github.com/hughsie/libxmlb/archive/$pkgver.tar.gz"
+subpackages="$pkgname-dev:_dev $pkgname-dbg $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hughsie/libxmlb/archive/refs/tags/$pkgver.tar.gz"
build() {
abuild-meson \
@@ -19,11 +19,11 @@ build() {
-Dstemmer=false \
-Dintrospection=true \
output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -34,8 +34,10 @@ package() {
_dev() {
default_dev
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/libexec "$subpkgdir"/usr
+
+ amove usr/bin/xb-tool
}
-sha512sums="4e082f036eb62626d1724ac5093ad625f9259e9e81aa40d5ca0589a3a72dadd669c0718ff64dcae094973b6c282b6c8f8ce7212b7e47211f320035bb639ec59d libxmlb-0.2.1.tar.gz"
+sha512sums="
+2576aca6b7651cf484694ad157914982ef1e3949ea641b4181966e5d5292b3d8c16318fe61b14d8c7e6d0e0d184ed30d498f874f5ada196f0ca69c6180d9061f libxmlb-0.3.18.tar.gz
+"