aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxpresent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libxpresent/APKBUILD')
-rw-r--r--community/libxpresent/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/libxpresent/APKBUILD b/community/libxpresent/APKBUILD
index 8f0d0296c53..f981bf48c33 100644
--- a/community/libxpresent/APKBUILD
+++ b/community/libxpresent/APKBUILD
@@ -1,22 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxpresent
-pkgver=1.0.0
-pkgrel=0
+pkgver=1.0.1
+pkgrel=3
pkgdesc="A Xlib-compatible API for the Present extension"
-url="http://xorg.freedesktop.org/"
+url="https://xorg.freedesktop.org/"
arch="all"
license="MIT"
-options="!check" # No test suite.
-depends=
-makedepends="xorgproto libx11-dev libxext-dev libxfixes-dev libxrandr-dev
- util-macros"
+makedepends="
+ libx11-dev
+ libxext-dev
+ libxfixes-dev
+ libxrandr-dev
+ util-macros
+ xorgproto
+ "
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.x.org/releases/individual/lib/libXpresent-$pkgver.tar.bz2"
-
-builddir="$srcdir"/libXpresent-$pkgver
+source="https://www.x.org/releases/individual/lib/libXpresent-$pkgver.tar.xz"
+options="!check" # No test suite
+builddir="$srcdir/libXpresent-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,8 +31,9 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="e88b4ec4fcbc0417a0cbecc0ecd73f8085c496dc6d1a4902b6550750a69a1cb8bb76c436c7941ee3bf3c61ffc85bbd8f8327fca30f14815dbef1cd53bb8db16b libXpresent-1.0.0.tar.bz2"
+sha512sums="
+a4551f49a68f4487eb70dc5b50b7f745fbc8b6842cfa60422afe3834af41c504a37bcfddb4e7e9ee084b250df256034290776c8eb7d8838e392eb626fff55d25 libXpresent-1.0.1.tar.xz
+"