aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxpresent/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libxpresent/APKBUILD')
-rw-r--r--community/libxpresent/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/libxpresent/APKBUILD b/community/libxpresent/APKBUILD
new file mode 100644
index 00000000000..9eb4b110caa
--- /dev/null
+++ b/community/libxpresent/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxpresent
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="A Xlib-compatible API for the Present extension"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="MIT"
+options="!check" # No test suite.
+depends=
+makedepends="xorgproto libx11-dev libxext-dev libxfixes-dev libxrandr-dev
+ util-macros"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.x.org/releases/individual/lib/libXpresent-$pkgver.tar.bz2"
+
+builddir="$srcdir"/libXpresent-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e88b4ec4fcbc0417a0cbecc0ecd73f8085c496dc6d1a4902b6550750a69a1cb8bb76c436c7941ee3bf3c61ffc85bbd8f8327fca30f14815dbef1cd53bb8db16b libXpresent-1.0.0.tar.bz2"