aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxres/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libxres/APKBUILD')
-rw-r--r--community/libxres/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/libxres/APKBUILD b/community/libxres/APKBUILD
new file mode 100644
index 00000000000..055aeb7161e
--- /dev/null
+++ b/community/libxres/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxres
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="X11 Resource extension library"
+url="http://xorg.freedesktop.org"
+arch="all"
+license="custom"
+options="!check" # No test suite.
+subpackages="$pkgname-dev $pkgname-doc"
+depends_dev="xorgproto"
+makedepends="$depends_dev libx11-dev libxext-dev util-macros"
+source="https://www.x.org/releases/individual/lib/libXres-$pkgver.tar.bz2
+ "
+
+builddir="$srcdir"/libXres-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="8eb5a36b1f030eb4e27e676cc4befcc073da66a7bce2b39089314e1facb629d13b087bb53ca2c95fe5291857da7ff9f80c6ab28fb3e245eeb9e0344937900172 libXres-1.2.0.tar.bz2"