aboutsummaryrefslogtreecommitdiffstats
path: root/community/libxxf86dga/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libxxf86dga/APKBUILD')
-rw-r--r--community/libxxf86dga/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/libxxf86dga/APKBUILD b/community/libxxf86dga/APKBUILD
new file mode 100644
index 00000000000..8a4aa78174c
--- /dev/null
+++ b/community/libxxf86dga/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libxxf86dga
+pkgver=1.1.5
+pkgrel=0
+pkgdesc="X11 Direct Graphics Access extension library"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="MIT"
+options="!check" # No test suite.
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="libxext-dev libx11-dev util-macros xorgproto"
+source="https://www.x.org/releases/individual/lib/libXxf86dga-$pkgver.tar.bz2"
+
+builddir="$srcdir"/libXxf86dga-$pkgver
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="0e77c4003aeba737b10c17d55aeefa935fc57c4ba9e8f79a834f3f8c690d6a1d98f69ad707eded784346c1cf40c41829719d257283b5eae3207147fb4c79ed89 libXxf86dga-1.1.5.tar.bz2"