aboutsummaryrefslogtreecommitdiffstats
path: root/community/libzim/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libzim/APKBUILD')
-rw-r--r--community/libzim/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/community/libzim/APKBUILD b/community/libzim/APKBUILD
index fd6f1b43132..8108d28f4dc 100644
--- a/community/libzim/APKBUILD
+++ b/community/libzim/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Oleg Titov <oleg.titov@gmail.com>
# Maintainer: Oleg Titov <oleg.titov@gmail.com>
pkgname=libzim
-pkgver=7.2.2
+pkgver=9.1.0
_testing_suite_ver=0.4
-pkgrel=0
+pkgrel=1
pkgdesc="Reference implementation of the ZIM file format"
url="https://openzim.org/"
arch="all"
@@ -11,7 +11,6 @@ license="GPL-2.0-or-later"
options="!check" #temporary disable tests
makedepends="
icu-dev
- libexecinfo-dev
meson
xapian-core-dev
xz-dev
@@ -24,19 +23,18 @@ checkdepends="
python3-dev
"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/openzim/libzim/archive/$pkgver.tar.gz
+source="$pkgname-$pkgver-2.tar.gz::https://github.com/openzim/libzim/archive/$pkgver.tar.gz
https://github.com/openzim/zim-testing-suite/releases/download/v$_testing_suite_ver/zim-testing-suite-$_testing_suite_ver.tar.gz
"
build() {
- LDFLAGS="$LDFLAGS -lexecinfo"
abuild-meson . output \
- -Dtest_data_dir="${srcdir}/zim-testing-suite/data"
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ -Dtest_data_dir="$srcdir/zim-testing-suite/data"
+ meson compile -C output
}
check() {
- SKIP_BIG_MEMORY_TEST=1 meson test --no-rebuild -v -C output
+ SKIP_BIG_MEMORY_TEST=1 meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -46,6 +44,6 @@ package() {
}
sha512sums="
-e95838feec7381717c3dac39f19c7197eed10c953c8ba3e36afd52e037d7b50b6c56c4ddb0a48e85f707390cd45e2c7e8d1f059fe1bcceb331fd983fe4afc115 libzim-7.2.2.tar.gz
+0f365024c31ee350972292979f729a82181ea94c708fae31118b71efa03cbf462ad1b879d9e314c4f28819ff40d73c3808d30d91c10e2af0aa8a81686ff82770 libzim-9.1.0-2.tar.gz
be2143c5bfab0b247dfbfe3e5c2bb1b58d786e5802be4f4a62ce694e6467f7713c5ccc1e1d4a933227cfc07016fc9d6ae1249d2d3cb29237a28750922dc671cb zim-testing-suite-0.4.tar.gz
"