aboutsummaryrefslogtreecommitdiffstats
path: root/community/libzim/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libzim/APKBUILD')
-rw-r--r--community/libzim/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/libzim/APKBUILD b/community/libzim/APKBUILD
new file mode 100644
index 00000000000..8108d28f4dc
--- /dev/null
+++ b/community/libzim/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=libzim
+pkgver=9.1.0
+_testing_suite_ver=0.4
+pkgrel=1
+pkgdesc="Reference implementation of the ZIM file format"
+url="https://openzim.org/"
+arch="all"
+license="GPL-2.0-or-later"
+options="!check" #temporary disable tests
+makedepends="
+ icu-dev
+ meson
+ xapian-core-dev
+ xz-dev
+ zlib-dev
+ zstd-dev
+ "
+checkdepends="
+ cython
+ gtest-dev
+ python3-dev
+ "
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver-2.tar.gz::https://github.com/openzim/libzim/archive/$pkgver.tar.gz
+ https://github.com/openzim/zim-testing-suite/releases/download/v$_testing_suite_ver/zim-testing-suite-$_testing_suite_ver.tar.gz
+ "
+
+build() {
+ abuild-meson . output \
+ -Dtest_data_dir="$srcdir/zim-testing-suite/data"
+ meson compile -C output
+}
+
+check() {
+ SKIP_BIG_MEMORY_TEST=1 meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+
+ install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md
+}
+
+sha512sums="
+0f365024c31ee350972292979f729a82181ea94c708fae31118b71efa03cbf462ad1b879d9e314c4f28819ff40d73c3808d30d91c10e2af0aa8a81686ff82770 libzim-9.1.0-2.tar.gz
+be2143c5bfab0b247dfbfe3e5c2bb1b58d786e5802be4f4a62ce694e6467f7713c5ccc1e1d4a933227cfc07016fc9d6ae1249d2d3cb29237a28750922dc671cb zim-testing-suite-0.4.tar.gz
+"