aboutsummaryrefslogtreecommitdiffstats
path: root/community/lightsoff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lightsoff/APKBUILD')
-rw-r--r--community/lightsoff/APKBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/community/lightsoff/APKBUILD b/community/lightsoff/APKBUILD
index 46b6679f90b..c40c74a938b 100644
--- a/community/lightsoff/APKBUILD
+++ b/community/lightsoff/APKBUILD
@@ -1,24 +1,33 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lightsoff
pkgver=40.0.1
-pkgrel=0
-arch="all !s390x !mips !mips64" # Blocked by librsvg -> rust
+pkgrel=2
+arch="all"
url="https://wiki.gnome.org/Apps/Lightsoff"
pkgdesc="Turn off all the lights"
license="GPL-2.0-or-later"
-makedepends="meson ninja itstool vala gtk+3.0-dev librsvg-dev clutter-dev clutter-gtk-dev"
+makedepends="
+ clutter-dev
+ clutter-gtk-dev
+ gtk+3.0-dev
+ itstool
+ librsvg-dev
+ meson
+ samurai
+ vala
+ "
checkdepends="desktop-file-utils"
source="https://download.gnome.org/sources/lightsoff/${pkgver%.*.*}/lightsoff-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {