aboutsummaryrefslogtreecommitdiffstats
path: root/community/liquidctl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/liquidctl/APKBUILD')
-rw-r--r--community/liquidctl/APKBUILD32
1 files changed, 22 insertions, 10 deletions
diff --git a/community/liquidctl/APKBUILD b/community/liquidctl/APKBUILD
index 0211fdd2dcb..24a3b1578e2 100644
--- a/community/liquidctl/APKBUILD
+++ b/community/liquidctl/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer:
pkgname=liquidctl
-pkgver=1.9.1
+pkgver=1.13.0
pkgrel=1
pkgdesc="Liquid Cooler Control"
url="https://github.com/liquidctl/liquidctl"
@@ -10,38 +10,50 @@ arch="noarch"
license="GPL-3.0-or-later"
depends="
py3-colorlog
+ py3-crcmod
py3-docopt
py3-hidapi
+ py3-pillow
py3-smbus
py3-usb
- python3
"
makedepends="
- py3-build
+ py3-gpep517
py3-installer
py3-setuptools
py3-setuptools_scm
py3-wheel
"
checkdepends="py3-pytest"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/liquidctl/liquidctl/archive/v$pkgver.tar.gz"
+prepare() {
+ default_prepare
+
+ # `uaccess` is (e)logind-specific.
+ sed -i 's/TAG+="uaccess"/GROUP="plugdev"/' extra/linux/71-liquidctl.rules
+}
+
build() {
export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
- python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 -m installer -d "$pkgdir" \
- dist/liquidctl-$pkgver-py3-none-any.whl
- install -Dm644 liquidctl.8 "$pkgdir"/usr/share/man/man8/liquidctl.8
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+ install -Dm644 extra/linux/71-liquidctl.rules -t "$pkgdir/usr/lib/udev/rules.d/"
+ install -Dm644 liquidctl.8 -t "$pkgdir/usr/share/man/man8/"
}
sha512sums="
-4f54c456cefe0a4628a361f65c3de51872c670ccc86188d4c1b3f1c179853e7875a7f2c5f2bfa7845c06318eb58cbafa134c5ff9834f473df7d05b2c21504fe4 liquidctl-1.9.1.tar.gz
+b909e31d892519d88be09d4bab94a864b4fe4bc83fe965c94fbfe2f6867ee423e0dd781942612a188dd787c5e6ff0cf27981d0ce13c266ba98543b23a4da09de liquidctl-1.13.0.tar.gz
"