aboutsummaryrefslogtreecommitdiffstats
path: root/community/liquidctl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/liquidctl/APKBUILD')
-rw-r--r--community/liquidctl/APKBUILD51
1 files changed, 39 insertions, 12 deletions
diff --git a/community/liquidctl/APKBUILD b/community/liquidctl/APKBUILD
index d24779f8fa1..24a3b1578e2 100644
--- a/community/liquidctl/APKBUILD
+++ b/community/liquidctl/APKBUILD
@@ -1,32 +1,59 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer:
pkgname=liquidctl
-pkgver=1.6.0
-pkgrel=0
+pkgver=1.13.0
+pkgrel=1
pkgdesc="Liquid Cooler Control"
url="https://github.com/liquidctl/liquidctl"
options="!check" # Requires writable /var/run
arch="noarch"
license="GPL-3.0-or-later"
-depends="python3 py3-docopt py3-usb py3-hidapi"
-makedepends="py3-setuptools"
+depends="
+ py3-colorlog
+ py3-crcmod
+ py3-docopt
+ py3-hidapi
+ py3-pillow
+ py3-smbus
+ py3-usb
+ "
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
+ "
checkdepends="py3-pytest"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/liquidctl/liquidctl/archive/v$pkgver.tar.gz"
+prepare() {
+ default_prepare
+
+ # `uaccess` is (e)logind-specific.
+ sed -i 's/TAG+="uaccess"/GROUP="plugdev"/' extra/linux/71-liquidctl.rules
+}
+
build() {
- DIST_NAME="$(source /etc/os-release && echo "$PRETTY_NAME")" \
- DIST_PACKAGE="$pkgname $pkgver-r$pkgrel" \
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- py.test-3
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
- install -Dm644 liquidctl.8 "$pkgdir"/usr/share/man/man8/liquidctl.8
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+ install -Dm644 extra/linux/71-liquidctl.rules -t "$pkgdir/usr/lib/udev/rules.d/"
+ install -Dm644 liquidctl.8 -t "$pkgdir/usr/share/man/man8/"
}
-sha512sums="9e9eb15c5efe9cde9d10f6352f38cdfc79792115d754a0193ebf5a47f766879a61da0feb08fb077992b826b121238ce30247fdfbda350f75762304e395d8539b liquidctl-1.6.0.tar.gz"
+sha512sums="
+b909e31d892519d88be09d4bab94a864b4fe4bc83fe965c94fbfe2f6867ee423e0dd781942612a188dd787c5e6ff0cf27981d0ce13c266ba98543b23a4da09de liquidctl-1.13.0.tar.gz
+"