aboutsummaryrefslogtreecommitdiffstats
path: root/community/liquidctl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/liquidctl/APKBUILD')
-rw-r--r--community/liquidctl/APKBUILD56
1 files changed, 44 insertions, 12 deletions
diff --git a/community/liquidctl/APKBUILD b/community/liquidctl/APKBUILD
index e1c13e21446..24a3b1578e2 100644
--- a/community/liquidctl/APKBUILD
+++ b/community/liquidctl/APKBUILD
@@ -1,27 +1,59 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
pkgname=liquidctl
-pkgver=1.3.3
-pkgrel=0
+pkgver=1.13.0
+pkgrel=1
pkgdesc="Liquid Cooler Control"
-url="https://github.com/jonasmalacofilho/liquidctl"
+url="https://github.com/liquidctl/liquidctl"
+options="!check" # Requires writable /var/run
arch="noarch"
license="GPL-3.0-or-later"
-depends="python3 py3-setuptools py3-docopt py3-usb py3-hidapi"
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jonasmalacofilho/liquidctl/archive/v$pkgver.tar.gz"
+depends="
+ py3-colorlog
+ py3-crcmod
+ py3-docopt
+ py3-hidapi
+ py3-pillow
+ py3-smbus
+ py3-usb
+ "
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
+ "
+checkdepends="py3-pytest"
+subpackages="$pkgname-doc $pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/liquidctl/liquidctl/archive/v$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+
+ # `uaccess` is (e)logind-specific.
+ sed -i 's/TAG+="uaccess"/GROUP="plugdev"/' extra/linux/71-liquidctl.rules
+}
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
- install -Dm644 liquidctl.8 "$pkgdir"/usr/share/man/man8/liquidctl.8
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+ install -Dm644 extra/linux/71-liquidctl.rules -t "$pkgdir/usr/lib/udev/rules.d/"
+ install -Dm644 liquidctl.8 -t "$pkgdir/usr/share/man/man8/"
}
-sha512sums="85a8e6cfd0eff36c842080539ac2aff9f31b3ff6a0a9a4e23b622a6d3a1ae5d40260b20e4077b064dcbc4c9353d801bab1fd547a72159d745e4081709f68e957 liquidctl-1.3.3.tar.gz"
+sha512sums="
+b909e31d892519d88be09d4bab94a864b4fe4bc83fe965c94fbfe2f6867ee423e0dd781942612a188dd787c5e6ff0cf27981d0ce13c266ba98543b23a4da09de liquidctl-1.13.0.tar.gz
+"