aboutsummaryrefslogtreecommitdiffstats
path: root/community/lld/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lld/APKBUILD')
-rw-r--r--community/lld/APKBUILD67
1 files changed, 0 insertions, 67 deletions
diff --git a/community/lld/APKBUILD b/community/lld/APKBUILD
deleted file mode 100644
index 90f8e6fc912..00000000000
--- a/community/lld/APKBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-# Contributor: Eric Molitor <eric@molitor.org>
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
-pkgname=lld
-pkgver=11.1.0
-pkgrel=0
-_llvmver=${pkgver%%.*}
-pkgdesc="The LLVM Linker"
-url="https://llvm.org"
-arch="all !mips !mips64"
-license="Apache-2.0"
-makedepends="
- cmake
- libedit-dev
- llvm$_llvmver-dev
- llvm$_llvmver-static
- llvm$_llvmver-test-utils
- zlib-dev"
-checkdepends="gtest gtest-dev bash"
-subpackages="$pkgname-static $pkgname-dev"
-source="https://github.com/llvm/llvm-project/releases/download/llvmorg-$pkgver/lld-$pkgver.src.tar.xz"
-builddir="$srcdir/$pkgname-$pkgver.src"
-
-# Tests OOM on 32-bit
-case "$CARCH" in
- s390x|x86|armhf|armv7) options="!check" ;;
-esac
-
-build() {
- mkdir -p "$builddir"/build
- cd "$builddir"/build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE=MinSizeRel \
- -DCMAKE_VERBOSE_MAKEFILE=OFF \
- -DCMAKE_C_FLAGS_MINSIZEREL_INIT="$CFLAGS" \
- -DCMAKE_CXX_FLAGS_MINSIZEREL_INIT="$CXXFLAGS -fpermissive" \
- -DCMAKE_EXE_LINKER_FLAGS_MINSIZEREL_INIT="$LDFLAGS -Wl,-z,stack-size=2097152" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_SKIP_INSTALL_RPATH=ON \
- -DLLVM_INCLUDE_TESTS=ON
- make
-}
-
-check() {
- cd "$builddir/build"
-
- # ELF/eh-frame-hdr-augmentation.s is broken on armhf & armv7
- case "$CARCH" in
- armhf|armv7) rm ../test/ELF/eh-frame-hdr-augmentation.s;;
- esac
-
- # make check-lld doesn't like using system lit
- lit -sv \
- --param lld_site_config=$builddir/build/test/lit.site.cfg \
- --param lld_unit_site_config=$builddir/build/test/Unit/lit.site.cfg \
- $builddir/build/test
-
-}
-
-package() {
- cd "$builddir"/build
-
- make install DESTDIR="$pkgdir"
-}
-
-sha512sums="3e249914ea73b2afb6575dc8c18e339fe0766784aeddb87cdbbca73ffc472509725e330b9c1b27d6909fb91c3755eb5f29f9dd1cc97ff6a59f17f913317d584f lld-11.1.0.src.tar.xz"