aboutsummaryrefslogtreecommitdiffstats
path: root/community/lmdbxx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lmdbxx/APKBUILD')
-rw-r--r--community/lmdbxx/APKBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/community/lmdbxx/APKBUILD b/community/lmdbxx/APKBUILD
index daa63d6375b..603d4e38bfb 100644
--- a/community/lmdbxx/APKBUILD
+++ b/community/lmdbxx/APKBUILD
@@ -1,21 +1,29 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=lmdbxx
-pkgver=0.9.14.0_git20160229
+pkgver=1.0.0
pkgrel=0
-_commit=0b43ca87d8cfabba392dfe884eb1edb83874de02
-pkgdesc="C++11 wrapper for the LMDB database library"
-options="!check"
-url="http://lmdbxx.sourceforge.net"
+pkgdesc="C++17 wrapper for the LMDB database library"
+url="https://github.com/hoytech/lmdbxx"
arch="noarch"
license="Unlicense"
makedepends="doxygen"
-# docs are available but require pandoc to be built which isn't packaged for Alpine
-source="https://github.com/drycpp/lmdbxx/archive/$_commit/lmdbxx-$_commit.tar.gz"
-builddir="$srcdir/$pkgname-$_commit"
+subpackages="$pkgname-doc"
+source="https://github.com/hoytech/lmdbxx/archive/$pkgver/lmdbxx-$pkgver.tar.gz"
+options="!check" # Requires itself to be installed
+
+build() {
+ make doxygen
+}
+
+check() {
+ make check
+}
package() {
- make DESTDIR="$pkgdir" PREFIX=/usr install
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -dm755 "$pkgdir"/usr/share/doc/lmdbxx
+ mv .doxygen/html "$pkgdir"/usr/share/doc/lmdbxx/
}
-sha512sums="025a945288a398b09549c91c98509a57912f8614c14b476e7c8d4fb0dc8fc1288fa1b3a33567cccea474277a1c48b3701f2df31e8a6acc851eb9549a9822f074 lmdbxx-0b43ca87d8cfabba392dfe884eb1edb83874de02.tar.gz"
+sha512sums="54f6c4863273b4de8aed6bc19f353c7a66d8ae633198e9784c55cea8e54460e4030ebe45e91a7c820aade084933f21cd4193ef8c04bb2aef11bf252281404171 lmdbxx-1.0.0.tar.gz"