aboutsummaryrefslogtreecommitdiffstats
path: root/community/lokalize/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lokalize/APKBUILD')
-rw-r--r--community/lokalize/APKBUILD46
1 files changed, 24 insertions, 22 deletions
diff --git a/community/lokalize/APKBUILD b/community/lokalize/APKBUILD
index 086e49662a3..65f7277f612 100644
--- a/community/lokalize/APKBUILD
+++ b/community/lokalize/APKBUILD
@@ -1,45 +1,47 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=lokalize
-pkgver=21.12.1
+pkgver=24.02.1
pkgrel=0
pkgdesc="Computer-Aided Translation System"
url="https://apps.kde.org/lokalize/"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
license="(GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
hunspell-dev
- kconfig-dev
- kcoreaddons-dev
- kcrash-dev
- kdbusaddons-dev
- kdoctools-dev
- ki18n-dev
- kio-dev
- knotifications-dev
- kross-dev
- kxmlgui-dev
+ kconfig5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdbusaddons5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kio5-dev
+ knotifications5-dev
+ kxmlgui5-dev
qt5-qtbase-dev
- sonnet-dev
+ samurai
+ sonnet5-dev
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/lokalize-$pkgver.tar.xz"
+checkdepends="xvfb-run"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/sdk/lokalize.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/lokalize-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ xvfb-run ctest --test-dir build --output-on-failure -E "(tmjobs|gettextheader)test"
}
package() {
@@ -47,5 +49,5 @@ package() {
}
sha512sums="
-d4e6b657437504ff2a6537c32c36bad0765879e46ef6255a507aa4707b5bf1710a5de4b5558d11e1b64f2b9e5edac680788baf8fc0b4997bb6d894e920d09d13 lokalize-21.12.1.tar.xz
+6c440e05424594f2d1d613bd2326bdc47e7ae61ba398831f9e3c8a68380171c070bf7a81a6020b4c855bef221250aa5257fc0f42bedbb98684cec118b57f1192 lokalize-24.02.1.tar.xz
"