aboutsummaryrefslogtreecommitdiffstats
path: root/community/lokalize/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lokalize/APKBUILD')
-rw-r--r--community/lokalize/APKBUILD48
1 files changed, 25 insertions, 23 deletions
diff --git a/community/lokalize/APKBUILD b/community/lokalize/APKBUILD
index 2518ff0a994..b80e29eb421 100644
--- a/community/lokalize/APKBUILD
+++ b/community/lokalize/APKBUILD
@@ -1,45 +1,47 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=lokalize
-pkgver=21.04.3
-pkgrel=1
+pkgver=24.02.2
+pkgrel=0
pkgdesc="Computer-Aided Translation System"
url="https://apps.kde.org/lokalize/"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
license="(GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
hunspell-dev
- kconfig-dev
- kcoreaddons-dev
- kcrash-dev
- kdbusaddons-dev
- kdoctools-dev
- ki18n-dev
- kio-dev
- knotifications-dev
- kross-dev
- kxmlgui-dev
+ kconfig5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdbusaddons5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kio5-dev
+ knotifications5-dev
+ kxmlgui5-dev
qt5-qtbase-dev
- sonnet-dev
+ samurai
+ sonnet5-dev
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/lokalize-$pkgver.tar.xz"
+checkdepends="xvfb-run"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/sdk/lokalize.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/lokalize-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ xvfb-run ctest --test-dir build --output-on-failure -E "(tmjobs|gettextheader)test"
}
package() {
@@ -47,5 +49,5 @@ package() {
}
sha512sums="
-b336fe464c123b60e4de4ba8bda0f34e2ba5eaf7708879179b9671bc33d8b031f81d595d089c24b4275ea56032e9867653cd98bf21c3d0c3db125564c057e21d lokalize-21.04.3.tar.xz
+6cb0dff01139146968d56269494a64f35635a51c9ab4845e69502bf3d5a686feedd00755f4a015cbc035fcaba00e8d6d3cfbdb448963127357a35ef91e629ff4 lokalize-24.02.2.tar.xz
"