aboutsummaryrefslogtreecommitdiffstats
path: root/community/lokalize/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lokalize/APKBUILD')
-rw-r--r--community/lokalize/APKBUILD45
1 files changed, 32 insertions, 13 deletions
diff --git a/community/lokalize/APKBUILD b/community/lokalize/APKBUILD
index 050792baeab..65f7277f612 100644
--- a/community/lokalize/APKBUILD
+++ b/community/lokalize/APKBUILD
@@ -1,34 +1,53 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=lokalize
-pkgver=21.04.2
+pkgver=24.02.1
pkgrel=0
pkgdesc="Computer-Aided Translation System"
-arch="all !armhf !s390x !mips64"
-url="https://kde.org/applications/office/org.kde.lokalize"
+url="https://apps.kde.org/lokalize/"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="(GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev ki18n-dev kio-dev kxmlgui-dev knotifications-dev kconfig-dev kcoreaddons-dev kdoctools-dev kross-dev sonnet-dev kdbusaddons-dev kcrash-dev hunspell-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/lokalize-$pkgver.tar.xz"
+makedepends="
+ extra-cmake-modules
+ hunspell-dev
+ kconfig5-dev
+ kcoreaddons5-dev
+ kcrash5-dev
+ kdbusaddons5-dev
+ kdoctools5-dev
+ ki18n5-dev
+ kio5-dev
+ knotifications5-dev
+ kxmlgui5-dev
+ qt5-qtbase-dev
+ samurai
+ sonnet5-dev
+ "
+checkdepends="xvfb-run"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/sdk/lokalize.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/lokalize-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ xvfb-run ctest --test-dir build --output-on-failure -E "(tmjobs|gettextheader)test"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-c88e547f0d1e9fe40b885adb453e3bf3efdf72f018cd5b1cad60bdd5323434805b59d8d1c5a32d6f60eae7809841aa45756cf5da89ac3241ea9d3b5536b4c202 lokalize-21.04.2.tar.xz
+6c440e05424594f2d1d613bd2326bdc47e7ae61ba398831f9e3c8a68380171c070bf7a81a6020b4c855bef221250aa5257fc0f42bedbb98684cec118b57f1192 lokalize-24.02.1.tar.xz
"