aboutsummaryrefslogtreecommitdiffstats
path: root/community/lowdown/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lowdown/APKBUILD')
-rw-r--r--community/lowdown/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/lowdown/APKBUILD b/community/lowdown/APKBUILD
new file mode 100644
index 00000000000..07829668b8c
--- /dev/null
+++ b/community/lowdown/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Sodface <sod@sodface.com>
+# Maintainer: Sodface <sod@sodface.com>
+pkgname=lowdown
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Simple markdown translator"
+url="https://kristaps.bsd.lv/lowdown/"
+arch="all"
+license="ISC"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://kristaps.bsd.lv/lowdown/snapshots/lowdown-$pkgver.tar.gz"
+
+build() {
+ # standalone configure script not generated by autoconf
+ ./configure PREFIX=/usr MANDIR=/usr/share/man LDFLAGS="$LDFLAGS"
+ make
+}
+
+check() {
+ make regress
+}
+
+package() {
+ make DESTDIR="$pkgdir" install install_libs
+}
+
+sha512sums="
+1290164f3ed9cbedaaa891a0ccbaedd2d2bb58467e8476ddcaacc098c89aa9ceae357b1c47cf208adebf51b4e3bc1f586a7bdeb6fc3d86e4aeca170e442108ba lowdown-1.1.0.tar.gz
+"