aboutsummaryrefslogtreecommitdiffstats
path: root/community/lowdown/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lowdown/APKBUILD')
-rw-r--r--community/lowdown/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/lowdown/APKBUILD b/community/lowdown/APKBUILD
index 02011e0583c..07829668b8c 100644
--- a/community/lowdown/APKBUILD
+++ b/community/lowdown/APKBUILD
@@ -1,18 +1,19 @@
# Contributor: Sodface <sod@sodface.com>
# Maintainer: Sodface <sod@sodface.com>
pkgname=lowdown
-pkgver=0.10.0
+pkgver=1.1.0
pkgrel=0
pkgdesc="Simple markdown translator"
url="https://kristaps.bsd.lv/lowdown/"
arch="all"
license="ISC"
-subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://kristaps.bsd.lv/lowdown/snapshots/lowdown-$pkgver.tar.gz"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://kristaps.bsd.lv/lowdown/snapshots/lowdown-$pkgver.tar.gz"
build() {
# standalone configure script not generated by autoconf
- ./configure PREFIX=/usr MANDIR=/usr/share/man
+ ./configure PREFIX=/usr MANDIR=/usr/share/man LDFLAGS="$LDFLAGS"
make
}
@@ -21,9 +22,9 @@ check() {
}
package() {
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install install_libs
}
sha512sums="
-52ba939eff32dfe2c0b4fa530e058cc3faee3b21babe312bc35a60e2c66d2ba4f577c23a46e1711231e1054afd4ee27df5c30d368839fb1d2d28fedc9d2b83df lowdown-0.10.0.tar.gz
+1290164f3ed9cbedaaa891a0ccbaedd2d2bb58467e8476ddcaacc098c89aa9ceae357b1c47cf208adebf51b4e3bc1f586a7bdeb6fc3d86e4aeca170e442108ba lowdown-1.1.0.tar.gz
"