aboutsummaryrefslogtreecommitdiffstats
path: root/community/ltunify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ltunify/APKBUILD')
-rw-r--r--community/ltunify/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/ltunify/APKBUILD b/community/ltunify/APKBUILD
new file mode 100644
index 00000000000..8bd53ed6c1a
--- /dev/null
+++ b/community/ltunify/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
+pkgname=ltunify
+pkgver=0.3
+pkgrel=1
+pkgdesc="Logitech Unifying tool for Linux"
+url="https://git.lekensteyn.nl/ltunify/"
+arch="all"
+license="GPL-3.0-or-later"
+source="https://github.com/Lekensteyn/ltunify/archive/v$pkgver/ltunify-$pkgver.tar.gz
+ no-execinfo.patch
+ "
+options="!check" # no test suite
+
+build() {
+ make PACKAGE_VERSION=$pkgver ltunify
+}
+
+package() {
+ make \
+ DESTDIR="$pkgdir" \
+ bindir=/usr/bin \
+ udevrulesdir=/lib/udev/rules.d \
+ install
+}
+
+sha512sums="
+f876de44b1b893bba2d8d44336f4936e639bd700d9dd22b46ef7ae11b731a6710c1154546272dd01c45d0e50d07c692c448c4be0b8d89d1e9772c3ed7575f626 ltunify-0.3.tar.gz
+5c4e650d3242ca485526dc9526e8392b458e1aef0c18a619cc14a7e3b74496975451247439ecde4a2484643631f91ac233ba216b90675eaddb6df000286174fe no-execinfo.patch
+"