aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-depgraph/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lua-depgraph/APKBUILD')
-rw-r--r--community/lua-depgraph/APKBUILD14
1 files changed, 2 insertions, 12 deletions
diff --git a/community/lua-depgraph/APKBUILD b/community/lua-depgraph/APKBUILD
index 0a77c92f087..2cd1b0a98f7 100644
--- a/community/lua-depgraph/APKBUILD
+++ b/community/lua-depgraph/APKBUILD
@@ -3,23 +3,16 @@
pkgname=lua-depgraph
_pkgname=depgraph
pkgver=0.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="A library and CLI tool for analyzing graph of dependencies between Lua modules"
url="https://github.com/mpeterv/depgraph"
arch="noarch"
license="MIT"
depends="lua lua-argparse lua-filesystem"
-makedepends=""
checkdepends="lua-busted"
source="$pkgname-$pkgver.tar.gz::https://github.com/mpeterv/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-# luajit is not available for selected arches
-case "$CARCH" in
- s390x) _luajit="";;
- *) checkdepends="$checkdepends luajit" _luajit="jit";;
-esac
-
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
@@ -27,10 +20,9 @@ for _v in $_luaversions; do
done
check() {
- cd "$builddir"
mkdir -p .bin
- local lver; for lver in $_luaversions $_luajit; do
+ local lver; for lver in $_luaversions; do
msg "Testing on lua$lver"
ln -sf /usr/bin/lua$lver .bin/lua
@@ -41,8 +33,6 @@ check() {
}
package() {
- cd "$builddir"
-
install -m 755 -D bin/luadepgraph.lua "$pkgdir"/usr/bin/luadepgraph
}