aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-http/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lua-http/APKBUILD')
-rw-r--r--community/lua-http/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/lua-http/APKBUILD b/community/lua-http/APKBUILD
index 28dd53ca157..cce8564fd54 100644
--- a/community/lua-http/APKBUILD
+++ b/community/lua-http/APKBUILD
@@ -8,7 +8,7 @@ url="https://github.com/daurnimator/lua-http"
arch="noarch"
license="MIT"
depends="lua-cqueues lua-basexx lua-fifo lua-lpeg lua-lpeg_patterns lua-ossl"
-checkdepends="lua-busted lua-compat53 lua5.1-bit32"
+checkdepends="lua-busted lua5.1-compat53 lua5.2-compat53 lua5.1-bit32"
makedepends=""
subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/daurnimator/$pkgname/archive/v$pkgver.tar.gz"
@@ -24,8 +24,8 @@ esac
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
+ checkdepends="$checkdepends lua$_v lua$_v-busted"
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
- checkdepends="$checkdepends lua$_v"
done
check() {