aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-resty-hmac/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lua-resty-hmac/APKBUILD')
-rw-r--r--community/lua-resty-hmac/APKBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/community/lua-resty-hmac/APKBUILD b/community/lua-resty-hmac/APKBUILD
index 3d3c6089b09..5a9aa81458a 100644
--- a/community/lua-resty-hmac/APKBUILD
+++ b/community/lua-resty-hmac/APKBUILD
@@ -1,30 +1,32 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=lua-resty-hmac
-pkgver=0.02.20180101
-_commitid=989f601acbe74dee71c1a48f3e140a427f2d03ae
-pkgrel=2
+pkgver=0.06
+_pkgver=$pkgver-1
+pkgrel=0
pkgdesc="HMAC functions for OpenResty"
url="https://github.com/jkeys089/lua-resty-hmac"
-arch="noarch"
+# ppc64le, riscv64 blocked by luajit -> nginx-mod-http-lua
+arch="noarch !ppc64le !riscv64"
license="BSD-2-Clause"
depends="nginx-mod-http-lua lua-resty-string"
-makedepends=""
checkdepends="perl-utils perl-test-nginx"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jkeys089/$pkgname/archive/$_commitid.tar.gz
- "
-builddir="$srcdir/$pkgname-$_commitid"
+source="$pkgname-$_pkgver.tar.gz::https://github.com/jkeys089/lua-resty-hmac/archive/refs/tags/$_pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$_pkgver"
package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/share/lua/common
- make DESTDIR="$pkgdir" LUA_LIB_DIR="$pkgdir/usr/share/lua/common" install
+ make DESTDIR="$pkgdir" LUA_LIB_DIR="/usr/share/lua/common" install
rm "$pkgdir/usr/share/lua/common/resty/string.lua"
}
check() {
- cd "$builddir"
- #make test LUA_LIB_DIR="$builddir/tmp"
+ local _modules=/usr/lib/nginx/modules
+ make test LUA_LIB_DIR="$builddir/tmp" MODULES=" \
+ $_modules/ndk_http_module.so \
+ $_modules/ngx_http_lua_module.so \
+ "
}
-sha512sums="9647d14722f5870805fd10f1539ca4235de63689279c92ce6f8c0cb21c590034cb1e8dc7b7bc5f5b216a68eebae281c4b0c4055c936c045bdd0aed990889c0c6 lua-resty-hmac-0.02.20180101.tar.gz"
+sha512sums="
+7cc5a84f8a8d4cd8e9fce13e98db39c5c96a734e236fe17dd0c663bd4fa506efadacf12bc8f416954b4d4fdea8b67a4339152f06a51b43858963bb3135e5becc lua-resty-hmac-0.06-1.tar.gz
+"