aboutsummaryrefslogtreecommitdiffstats
path: root/community/lua-turbo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/lua-turbo/APKBUILD')
-rw-r--r--community/lua-turbo/APKBUILD23
1 files changed, 5 insertions, 18 deletions
diff --git a/community/lua-turbo/APKBUILD b/community/lua-turbo/APKBUILD
index 6850a11fa80..7d6d09f80f0 100644
--- a/community/lua-turbo/APKBUILD
+++ b/community/lua-turbo/APKBUILD
@@ -2,10 +2,9 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=lua-turbo
-_jitver=2.1.0-beta3
pkgver=2.1.3
-pkgrel=4
-pkgdesc="a framework built for LuaJIT 2 and Linux"
+pkgrel=5
+pkgdesc="framework built for LuaJIT 2 and Linux"
url="https://github.com/kernelsauce/turbo"
arch="all"
license="Apache-2.0"
@@ -25,17 +24,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/kernelsauce/turbo/archive/v$
builddir="$srcdir/turbo-$pkgver"
prepare() {
- cd "$builddir"
default_prepare
- # check if we are using the current luajit version
- if [ -r ../../../../main/luajit/APKBUILD ]; then
- local _currentjit=$(grep "^_compatver=" ../../../../main/luajit/APKBUILD)
- if [ "${_currentjit#*=}" != "$_jitver" ]; then
- die "luajit version does not match: ${_currentjit#*=} != $_jitver !"
- fi
- else
- die "cannot locate luajit APKBUILD!"
- fi
# we need to fix the loading of libssl.
local _soname=$(scanelf --nobanner --soname /usr/lib/libssl.so | awk '{print $2}')
sed -i -e \
@@ -44,17 +33,15 @@ prepare() {
}
build() {
- cd "$builddir"
- export LUAJIT_VERSION="${_jitver/_/-}"
+ export LUAJIT_VERSION="$(pkgconf luajit --variable=version)"
make
}
package() {
- cd "$builddir"
make PREFIX="$pkgdir"/usr install
- install -Dm 755 "$srcdir"/${pkgname}.initd \
+ install -Dm 755 "$srcdir"/$pkgname.initd \
$pkgdir/etc/init.d/$pkgname
- install -Dm 644 "$srcdir"/${pkgname}.confd \
+ install -Dm 644 "$srcdir"/$pkgname.confd \
$pkgdir/etc/conf.d/$pkgname
# we use luajit only
rm -rf "$pkgdir/usr/share/lua"